Rangecast FAQ
[FAQ-1168] Original Rangecast Player may not work with Chrome, Firefox and Opera browsers


Page Type: SOLUTION


OVERVIEW

Some users will need to install older browser versions to continue using the original Rangecast JAVA language player. JAVA has been removed from Chrome, Firefox and Opera due to security issues. Older versions will still work. Note -- Internet Explorer may currently support JAVA.

Firefox version 44.0 will work. It can be downloaded from http://rangecast.com/resource. After installing, automatic updating MUST BE TURNED OFF as shown here.



Rangecast FAQ - ID 1168 - last updated 02 August 2017     Images shown - [block]